Iron Speed Technical Forums
Register Latest Topics
 
 
 


Reply
  Author   Comment  
Goran

Registered:
Posts: 22
Reply with quote  #1 
I have migrated an application from 10.2.1 to 11.0.0

After some minor problems with themes and java script the application works fine in
the development environment. However the application cant be deployed.

I get error messages like "Unknown server tag" and "Circular file references are not allowed" when
trying to deploy it .

Has anyone got a clue ?

Goran

(Deploying the application i in 10.2.1 works fine)


=============

The output looks like this:

 Microsoft (R) Build Engine Version 4.0.30319.1
 [Microsoft .NET Framework, Version 4.0.30319.2034]
 Copyright (C) Microsoft Corporation 2007. All rights reserved.
      
 Build started 2014-07-31 10:32:59.
 Project "C:\AlkTSS5_Deploy\deploy\deploy.wdproj" on node 1 (default targets).
      _PrepareForBuild:
        Creating directory "obj\Release\".
      AspNetCompiler:
        C:\WINDOWS\Microsoft.NET\Framework\v4.0.30319\aspnet_compiler.exe -v /AlkTSS4 -p C:\AlkTSS5 -u -f obj\Release\TempBuildDir 
      /AlkTSS4/Header and Footer/HeaderMobile.ascx(1): error ASPPARSE: Circular file references are not allowed. [C:\AlkTSS5_Deploy\deploy\deploy.wdproj]
      /AlkTSS4/Header and Footer/HeaderMobile.ascx(13): error ASPPARSE: Unknown server tag 'AlkTSS4:ThemeButtonMobile'. [C:\AlkTSS5_Deploy\deploy\deploy.wdproj]
      /AlkTSS4/Menu Panels/StartMobile.aspx(24): error ASPPARSE: Unknown server tag 'AlkTSS4:HeaderMobile'. [C:\AlkTSS5_Deploy\deploy\deploy.wdproj]
      /AlkTSS4/Master Pages/HorizontalMenu.master(30): error ASPPARSE: Unknown server tag 'AlkTSS4:Menu'. [C:\AlkTSS5_Deploy\deploy\deploy.wdproj]
      /AlkTSS4/Header and Footer/HeaderMobile.ascx(1): error ASPPARSE: Circular file references are not allowed. [C:\AlkTSS5_Deploy\deploy\deploy.wdproj]
      /AlkTSS4/Header and Footer/HeaderMobile.ascx(13): error ASPPARSE: Unknown server tag 'AlkTSS4:ThemeButtonMobile'. [C:\AlkTSS5_Deploy\deploy\deploy.wdproj]
      Done Building Project "C:\AlkTSS5_Deploy\deploy\deploy.wdproj" (default targets) -- FAILED.
 
TrucMi

Registered:
Posts: 220
Reply with quote  #2 
I have the similar error when trying to deploy, the same application deployed fine a month ago without any changes in my application???  I'm using IronSpeed V9.2 .Framework 4.0.  Does anyone have a clue to where I should be checking to correct this? Thanks in advance.

------ Build started: Project: C:\CONTACT\, Configuration: Debug Any CPU ------

Pre-compiling Web Site

 

Building directory '/CONTACT/App_GlobalResources/'.

Building directory '/CONTACT/App_Code/'.

Building directory '/CONTACT/Account/'.

Building directory '/CONTACT/Master Pages/'.

Building directory '/CONTACT/Menu Panels/'.

Building directory '/CONTACT/Header and Footer/'.

Building directory '/CONTACT/Shared/'.C:\CONTACT\Shared\ImportData.aspx(1): Publication (web): Circular file references are not allowed.

C:\CONTACT\Shared\ImportData.aspx(58): Publication (web): Unknown server tag 'CONTACT:ThemeButton'.

C:\CONTACT\Shared\ImportData.aspx(60): Publication (web): Unknown server tag 'CONTACT:ThemeButton'.

C:\CONTACT\Shared\LargeListSelector.aspx(10): Publication (web): Circular file references are not allowed.

C:\CONTACT\Shared\LargeListSelector.aspx(70): Publication (web): Unknown server tag 'CONTACT:ThemeButton'.

C:\CONTACT\Shared\SelectFileToImport.aspx(1): Publication (web): Circular file references are not allowed.

C:\CONTACT\Shared\SelectFileToImport.aspx(144): Publication (web): Unknown server tag 'CONTACT:Themebutton'.

C:\CONTACT\Shared\DatePagination.ascx(3): Publication (web): Circular file references are not allowed.

C:\CONTACT\Shared\DatePagination.ascx(10): Publication (web): Unknown server tag 'CONTACT:ThemeButton'.

C:\CONTACT\Shared\DatePagination.ascx(10): Publication (web): Unknown server tag 'CONTACT:ThemeButton'.

C:\CONTACT\Shared\DatePagination.ascx(16): Publication (web): Unknown server tag 'CONTACT:ThemeButton'.

C:\CONTACT\Shared\DatePagination.ascx(16): Publication (web): Unknown server tag 'CONTACT:ThemeButton'.

C:\CONTACT\Account\AddAccount.aspx(74): Publication (web): Unknown server tag 'CONTACT:ThemeButton'.

C:\CONTACT\Account\AddAccount.aspx(74): Publication (web): Unknown server tag 'CONTACT:ThemeButton'.

C:\CONTACT\Account\AddAccount.aspx(74): Publication (web): Unknown server tag 'CONTACT:ThemeButton'.

 

Pre-compilation Complete

------ Skipped Publish: Project C:\CONTACT\, Configuration: Debug Any CPU ------

 

========== Build: 0 succeeded or up-to-date, 1 failed, 0 skipped ==========

========== Publish: 0 succeeded, 0 failed, 1 skipped ==========

Kirill

Avatar / Picture

Registered:
Posts: 223
Reply with quote  #3 
Unfortunately exactly same application can throw this error at some point and not at another. Sometimes Microsoft Build fails to resolve references. Somehow it is related to environment, caching, etc. Sometimes it helps to for example move MobileHeader to another folder (easy to do, just copy all three files to another folder and change references on mobile pages). We are still trying to figure out why this happens. This problem was there since release 9, I believe and we still can't find a reasonable way to solve it.
Of course you always can use xcopy to move your application to a server...
miles

Avatar / Picture

MVP Consultant
Registered:
Posts: 1,659
Reply with quote  #4 
Have you tried loading the application into Visual Studio and doing a ReBuild All from there?  That might solve the problem, or at least provide better clues as to what is going on.  Just a thought.

HTH,

__________________
Miles Gibson, MScIS
Iron Speed MVP
Senior Consultant, Principal
Milestone Software Inc.

http://www.ironspeedmvp.com\localizer 
Email: miles@milestone.ca
Milestone Localizer: Full Localization for your Iron Speed applications!
Kirill

Avatar / Picture

Registered:
Posts: 223
Reply with quote  #5 
OK, here is a temporary solution. Bug fix will be released soon.

Problem is that the StartMobile.aspx uses HeaderMobile.ascx control which has a theme button on it, that is referencing to ThemeButtonMobile.ascx control present in the Shared folder. This referencing cause a circular reference issue when deployment project is build. To resolve this issue, create a copy of ThemeButtonMobile.ascx control and place it in the Header and Footer folder. Now go to the HeaderMobile.ascx control, here go in the PageHeaderButtons section, where you will find SignIn button control. From the property sheet, change the path to copied theme button control.

garybloor

Registered:
Posts: 4
Reply with quote  #6 
I have had the same issue as TrucMi for nearly three weeks now and although I've slowly worked my way through all the errors, reinstalling VS, ISD, .net and so on. Many of them are cleared by rebuilding in ISD before publishing in VS. (oh for the days of one stop ISD). BUT the ' Object reference not set to an instance of an object. ' remains. It shows up in ISD AND VS (2010 SP1) consistently. It seemed to start when I upgraded to ISD11.0.1 and  then ISD 11.1.0 but that could be a coincidence as a lot of other stuff happened at that time. Problem is also seen on older ISD10.2.1 apps. 

Obj Not Obj.jpg 
Research suggests its something to do with when the manifest version in microsoft.web.is checked with (something) and it does not match. we think there is a dependency on an installed component on the PC, but short of hoping for a resolution by doing a complete PC rebuild, we are all out of ideas. (and we're quite desperate. The app is too large to regenerate/rekey). Note we have also tried this with different apps and all give the same issue.

garybloor

Registered:
Posts: 4
Reply with quote  #7 
Would add that I have uninstalled and reinstalled web deployment v2.0
oeg2015

Registered:
Posts: 3
Reply with quote  #8 
Hi

I'm having the same problem.
But in my case I migrated from V9.2 to v11.1

I did was you sugests but now I have two more pages that shows the error

Can you suggest me something to solve this problem?

Thanks

JimiJ

Avatar / Picture

MVP Developer
Registered:
Posts: 1,954
Reply with quote  #9 
I am trying to duplicate error by migrating V9.2 to 11.1 App but to no avail. Everything went smoothly.
__________________

  Jaime Jegonia
[jts_logo]

Iron Speed MVP Developer
 

". . . and whoever sows generously will also reap generously" 2 Cor 9:6

Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.

Download Iron Speed Designer

Terms of Service Privacy Statement