Iron Speed Technical Forums
Register Latest Topics
 
 
 


Reply
  Author   Comment   Page 4 of 6      Prev   1   2   3   4   5   6   Next
miles

Avatar / Picture

MVP Consultant
Registered:
Posts: 1,685
Reply with quote  #46 
I am going to see if I can block access from my router, my firewall router that is.  Completely separate from Windows.  Not sure how or if this could work, but I will let you know what I find out.

Cheers,

__________________
Miles Gibson, MScIS
Iron Speed MVP
Senior Consultant, Principal
Milestone Software Inc.

http://www.ironspeedmvp.com\localizer 
Email: miles@milestone.ca
Milestone Localizer: Full Localization for your Iron Speed applications!
bowskill

Registered:
Posts: 60
Reply with quote  #47 
No harm in that extra protection Miles.

I just downloaded wireshark and ran it. It has confirmed that with the firewall rules on, no data gets to the license server.

On that basis, I'm happy to keep just using windows firewall. Think I'm done on this issue now! But it's extremely important to us all so I wanted us to get to the bottom of it.
jackobee

Registered:
Posts: 32
Reply with quote  #48 
Although I have it installed and I also recently ran into the License Issue (and resolved it) I could not find "Ironspeed" or "Designer" within the list of Windows Firewall apps.  Any ideas?

Thank You,
John
ikrami2000

Registered:
Posts: 222
Reply with quote  #49 
ISD Activation change Apllication setting which in program files and or Registry ?

if just program files, so copy your existing ISD folder and save it to another location and if the license changed, disable internet and copy the old ISD files into program files,  work into environment without internet
SkyForum

Registered:
Posts: 50
Reply with quote  #50 
You guys have me so worried about this that I now completely disconnect from the internet before I ever open ISD. Once I've completed my project work and created my install file on my machine, I then close ISD, then reconnect my internet and upload the file to my server and install. PITA.....
__________________
As you get older, your patience begins to wane. As a result, you become the "Grumpy Old Guy".  At 60 years of age I have become this guy. I am now faced with the dilemma of an old dog learning new relationship tricks to survive. [rolleyes]
JimiJ

Avatar / Picture

MVP Developer
Registered:
Posts: 1,962
Reply with quote  #51 
Quote:
Originally Posted by jackobee
Although I have it installed and I also recently ran into the License Issue (and resolved it) I could not find "Ironspeed" or "Designer" within the list of Windows Firewall apps.  Any ideas?

Thank You,
John


If can't find, you may add it:

http://www.simplehelp.net/2015/09/02/how-to-block-a-program-from-the-internet-in-windows-10/


Jimi J

__________________

  Jaime Jegonia
[jts_logo]

Iron Speed MVP Developer
 

". . . and whoever sows generously will also reap generously" 2 Cor 9:6

bowskill

Registered:
Posts: 60
Reply with quote  #52 
Thats a good link Jimi posted but if you need Designer to connect to a database on another machine then you may have to modify the rules.

I will post a video in a day or so summarising what we know about the licensing process and steps that can be taken. There are a couple more tricks not yet mentioned here. But everybody should at least be firewalling designer by now.
Dwight

Registered:
Posts: 20
Reply with quote  #53 
My solution which may or may not work does not involve the Windows Firewall, but rather reroutes the call to Iron Speed and the Activation Server, it reroutes to a unsolvable address.

It requires you to modify the the host file located here on a windows 7 machine.

c:\Windows\System32\Drivers\etc\hosts


Copy the hosts file to your desktop (you cant modify it in the windows folder.)

Open it using Notepad

Add these line to the top.

0.0.0.0 0.0.0.0
0.0.0.0 acs.ironspeed.com
0.0.0.0 http://www.ironspeed.com

****The third line should not have the "http://" this forum is adding it automatically. *****


Save and replace the original with your saved file.

Viewing with fiddler after making these changes, shows that it does not connect to either addresses.

Capture.PNG 
Dwight




porphi

Registered:
Posts: 648
Reply with quote  #54 

Dwight,

That's basically what I did also. Instead I used the local loopback so that a 404 would be returned. It also works on Windows 10. There was one version that used a hard coded IP address though.

If you're looking to just block access to the activation service, you can add this entry; "127.0.0.1  acs.ironspeed.com" (without the quotes and there is a tab between the ip address and the domain name) into the hosts file. The hosts file can be edited with notepad.exe but it needs to be runas administrator.

The file is located in the folder \windows\system32\drivers\ect\.

Remember if you want to uninstall a copy of the designer you need to remark out the line or the uninstall won’t be able to access the server. You can remark out the line by add a hash tag before the entry; #127.0.0.1 acs.ironspeed.com

If you run fiddler/wireshark, etc… you’ll notice that a 404 not found is returned.

I would still be cautious with any of these techniques as no one except the designers of IS know what other technique is in use to prohibit the software from running.

 


__________________
Thank you,
Phil Porter
PPG&A, INC.
pporter@ppgainc.com
http://www.ppgainc.com
https://rapidsprout.com
678-362-2035
Dwight

Registered:
Posts: 20
Reply with quote  #55 
Quote:
Originally Posted by porphi

 

If you're looking to just block access to the activation service, you can add this entry; "127.0.0.1 acs.ironspeed.com" (without the quotes) into the hosts file. 

 



I did have it set up as 127.0.0.1 at first, but setting it to 0.0.0.0 seems to load faster.


Dwight
jackobee

Registered:
Posts: 32
Reply with quote  #56 
This stategy did not save me in today's license outage
annaedson

Registered:
Posts: 6
Reply with quote  #57 
I need Help urgently. Is the server down?

I am running version 9.1.1. It suddenly asked me to register. I tried entering the info but it wanted me to uninstall first. I uninstalled and then reinstalled, but it is not registering the uninstall and will not let me register.


Any help will be appreciated. I am desperate.

ikrami2000

Registered:
Posts: 222
Reply with quote  #58 
Do you have backup from your old installed 
annaedson

Registered:
Posts: 6
Reply with quote  #59 
Unfortunately, I do not have a mirror backup. I just backup folders and files.
RRivera

Registered:
Posts: 2
Reply with quote  #60 
Quote:
Originally Posted by jackobee
This stategy did not save me in today's license outage


Are you saying the the host file option did not work?
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.

Download Iron Speed Designer

Terms of Service Privacy Statement