Iron Speed Technical Forums
Register Latest Topics
 
 
 


Reply
  Author   Comment  
jdmsoftware

Avatar / Picture

Registered:
Posts: 8
Reply with quote  #1 
Well, I configured my SMTP server info using the Configure Email Server Connection page from the Tools menu and can receive test emails when I click on "Send test email" BUT I am not receiving an email when I try it using my application.

I am using database security and ver 9.01 of ISD. Hosted Exchange Server.

Anyone else having email problems or any ideas?

__________________
John D. Mischler
JDM Software, Inc.

"The secret to creativity is knowing how to hide your sources." - Albert Einstein
akeshgupta

Avatar / Picture

Iron Speed MVP
Design, Develop & Deliver

Registered:
Posts: 1,095
Reply with quote  #2 

John:  Please make sure that you have selected the Email field of User Account in the Security wizard.  Things are working just fine at my end without doing any customization.


__________________
Akesh Gupta
Light Speed Solutions, LLC.
If I rest, I will rust !   Let's share the knowledge !
jdmsoftware

Avatar / Picture

Registered:
Posts: 8
Reply with quote  #3 
I believe my User security is setup properly?



Does this look correct?

__________________
John D. Mischler
JDM Software, Inc.

"The secret to creativity is knowing how to hide your sources." - Albert Einstein
akeshgupta

Avatar / Picture

Iron Speed MVP
Design, Develop & Deliver

Registered:
Posts: 1,095
Reply with quote  #4 

Yes. At this point, I would recommend another smtp server just to rule out that option.  As mentioned, it has worked for me quite well without any customization beyond what you have done.


__________________
Akesh Gupta
Light Speed Solutions, LLC.
If I rest, I will rust !   Let's share the knowledge !
lnadai

Registered:
Posts: 63
Reply with quote  #5 
You may want to look at the web.config if everything has been generated correctly.
Check the SMTP section under mailsettings.

jdmsoftware

Avatar / Picture

Registered:
Posts: 8
Reply with quote  #6 
Akesh,

You were correct. I used a standard POP3/SMTP server, and the email is now working.

Tip to everyone - don't use Exchange Server for the SMTP outgoing email.

Now, I see an email logo (@ Email logo goes here). Where is the body of the email so I can replace the logo image?

Thanks.

__________________
John D. Mischler
JDM Software, Inc.

"The secret to creativity is knowing how to hide your sources." - Albert Einstein
akeshgupta

Avatar / Picture

Iron Speed MVP
Design, Develop & Deliver

Registered:
Posts: 1,095
Reply with quote  #7 

You can replace the logo in the images folder.  Just copy your logo with the same name and it will work.

 

I am glad that things worked out.


__________________
Akesh Gupta
Light Speed Solutions, LLC.
If I rest, I will rust !   Let's share the knowledge !
jdmsoftware

Avatar / Picture

Registered:
Posts: 8
Reply with quote  #8 
Did some digging.

You can also change the email logo by going to the Header and Footer folder, EmailHeader.ascx page - click on the "Logo" cell A1 and change the ImageURL path under Properties.

Thanks.

__________________
John D. Mischler
JDM Software, Inc.

"The secret to creativity is knowing how to hide your sources." - Albert Einstein
AltVader

Registered:
Posts: 32
Reply with quote  #9 

I'm having the same problem originally reported: converted an app from 8.02 to 9.0.1. Set the email field in the security wizard. Run the app, go to lost password, enter email address. UI indicates the email was sent but one never arrives. Emails are sent successfully from a different place in the app, suggesting SMTP is ok.. any ideas?

SkyForum

Registered:
Posts: 50
Reply with quote  #10 
I have the exact same issue with version 12.2. All email works except forgot user. My passwords are encrypted. Any ideas?
__________________
As you get older, your patience begins to wane. As a result, you become the "Grumpy Old Guy".  At 60 years of age I have become this guy. I am now faced with the dilemma of an old dog learning new relationship tricks to survive. [rolleyes]
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.

Download Iron Speed Designer

Terms of Service Privacy Statement