Iron Speed Technical Forums
Sign up Latest Topics
 
 
 


Reply
  Author   Comment  
andrewc

Registered:
Posts: 20
Reply with quote  #1 

Hi

I tried to deploy a simple app from version 12.0.2 to a Windows Server 2016 running IIS 10.

There is no Deploy option when I right click on Default Website in the IIS management console.

Has anyone else successfully deployed a VB Web Application (Compiled DLL) to IIS 10 on Windows Server 2016? If so do you have any tips.

Thanks

Andrew

ikrami2000

Registered:
Posts: 231
Reply with quote  #2 
please check the below link to give you step by step install IIS correctly :


https://www.rootusers.com/how-to-install-iis-in-windows-server-2016/


andrewc

Registered:
Posts: 20
Reply with quote  #3 
Thanks ikrami2000

I have made sure that all of the components that are outlined in the link you sent are installed but still no Deploy option when I right click on the default website.

Regards

Andrew
ikrami2000

Registered:
Posts: 231
Reply with quote  #4 
What do you mean by deploy option

1- copy your deployed app to c:\inetpub/wwww folder
2- in iis you can this folder, right click on it then convert to application
andrewc

Registered:
Posts: 20
Reply with quote  #5 
Hi

I tried what you suggested with the following testapp_Deploy folder but I still can't get the site working:

testapp.jpg  Thanks

Andrew

ikrami2000

Registered:
Posts: 231
Reply with quote  #6 
The deployed app inside the zip file
nestor

Registered:
Posts: 118
Reply with quote  #7 
I'm not sure about Server 2016, but I had similar issues with IIS 10 and Windows 10.
Had to install a web deploy package (WebDeploy_amd64_en-US.msi).
Have you tried this link? 

https://stackoverflow.com/questions/41386690/missing-import-web-application-option-in-web-deploy-3-6
ikrami2000

Registered:
Posts: 231
Reply with quote  #8 
As they mentioned

Try to run IIS as administrator and you should see the Import Web Application" option and The "Export Web Application"
andrewc

Registered:
Posts: 20
Reply with quote  #9 
Thanks for your help. I finally got the app deployed.

I had to install the Web Platform Installer:
https://www.microsoft.com/web/downloads/platform.aspx

This then gave me the option to install Web Deploy 3.6

Even after installing Web Deploy I didn't have the Deploy options in IIS Manager (even running as Administrator). So I used the Publish Web App option in Visual Studio which then gave me the option to use Web Deploy to deploy the App.

Andrew

ikrami2000

Registered:
Posts: 231
Reply with quote  #10 
[smile]  good
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.

Download Iron Speed Designer

Terms of Service Privacy Statement