Iron Speed Technical Forums
Register Latest Topics
 
 
 


Reply
  Author   Comment  
AKnowles

Registered:
Posts: 50
Reply with quote  #1 
I have a trigger that is supposed to fire after each item in an order is added. What happens is that it doesn't appear to fire when I add an item, BUT it does fire if I add another line with the same item.

Does anyone have any ideas on this?  It is very puzzling and frustrating.

Thanks,
Angela

__________________
Angela Knowles
JimiJ

Avatar / Picture

MVP Developer
Registered:
Posts: 1,954
Reply with quote  #2 
Our current projects are heavy on triggers (both on CLR and DML) but I never had any issue. There are events, types and constraints that you must carefully consider.  
ref: https://msdn.microsoft.com/en-us/library/ms178110.aspx

__________________

  Jaime Jegonia
[jts_logo]

Iron Speed MVP Developer
 

". . . and whoever sows generously will also reap generously" 2 Cor 9:6

AKnowles

Registered:
Posts: 50
Reply with quote  #3 
I also have many triggers in my app and this is the only one that acts like this. Very strange behavior based on my 20+ years experience with SQL Server.

What I am wondering is if there is something about inserting/saving the first row on a record table that makes it do this.

So puzzling.

__________________
Angela Knowles
JimiJ

Avatar / Picture

MVP Developer
Registered:
Posts: 1,954
Reply with quote  #4 
Are you using any IRecordWithTriggerEvents in the Business Layer?
__________________

  Jaime Jegonia
[jts_logo]

Iron Speed MVP Developer
 

". . . and whoever sows generously will also reap generously" 2 Cor 9:6

Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.

Download Iron Speed Designer

Terms of Service Privacy Statement